View Issue Details

IDProjectCategoryView StatusLast Update
0022000Return of ReckoningAbilitiespublic2024-06-16 22:05
ReporterOmegus Assigned ToEmissary  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0022000: Zealot: transference tactic missing 10% disrupt strike-through
DescriptionOne of the ROR changes made to the Transference tactic (as well as the Rune Priest mirror - Efficient Runecarving) was that the tactic also added 10% disrupt strike-through. This was listed on the tooltip for the RP tactic but not the Zealot tactic. There was previously an open ticket to get the Transference tooltip updated to include the disrupt strike-through:

https://bugs.returnofreckoning.com/view.php?id=19147

Under the new ability system, the 10% disrupt strike-through on Transference appears to have been lost completely as it is still missing from the tooltip and it is now also missing from .getstats. There was no mention of this being a balance change so I am assuming it is a bug and has been removed by accident. Previously the disrupt strike-through was being applied regardless of Harbinger mode, but I do not know if that part was a bug or intended as the life-tap part of the tactic was also applying in both Harbinger modes.

I do not have a R40 Rune Priest to test if Efficient Runecarving still grants 10% disrupt strike-through.
Steps To Reproduce1) R40 Zealot
2) Spec for the Transference tactic (11 points in the Witchcraft tree)
3) Equip tactic
4) Select self and do .getstats, see there is no 10% disrupt strikethrough listed.
5) Toggle Harbinger of Doom from off-to-on, or on-to-off
6) Select self and do .getstats, see there is no 10% disrupt strikethrough listed.
7) Confirmation that the 10% disrupt strike-through is missing from both Harbinger modes.
TagsNo tags attached.

Activities

Emissary

Emissary

2024-06-16 22:05

manager   ~0043507

Hi Omegus,

Thank you for your detailed report regarding the Transference tactic for Zealots. You are correct that the 10% disrupt strike-through should be included as part of the Transference tactic. This issue has been identified and fixed, and the correction will be implemented in the next patch.

If you have any further questions or encounter additional issues, please feel free to reach out.

Best regards,
Emissary

Issue History

Date Modified Username Field Change
2024-01-01 15:51 Omegus New Issue
2024-06-12 20:07 Emissary Assigned To => Emissary
2024-06-12 20:07 Emissary Status new => assigned
2024-06-16 22:05 Emissary Status assigned => resolved
2024-06-16 22:05 Emissary Resolution open => fixed
2024-06-16 22:05 Emissary Note Added: 0043507