View Issue Details

IDProjectCategoryView StatusLast Update
0022637Return of ReckoningAbilitiespublic2024-07-07 10:06
ReporterCyunUnderis Assigned Todalen  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Summary0022637: [PTS] - [Ironbreaker] - Oathstone gives 100% block for 10sc despite the 4 hits returned
DescriptionOn live, Oathstone have the following description :

> You declare that this is where you're making your stand, and nothing will make you change your mind. You are almost guaranteed to block up to the next 4 attacks made against you within 10 seconds, and you will deal 150 damage back to the attacker each time you block.

On the PTS, the description didn't change. It should have information about the change included in the patch note :

> Now additionally gives 6s of Immovable to you and your Oath Friend if they are within 50 ft

Also, Oathstone provides 100% block during 10 sc, despite the 4 hits taken.

https://youtu.be/Oxp7fOvQcSo

The immunity that the spell gives is Unstoppable and not Immovable.
TagsNo tags attached.

Relationships

has duplicate 0022917 closedEmissary Flame's Kiss wont make flickering red fire undefendable against oathstone 
has duplicate 0022923 closeddalen oathstone of ib (snb) is bugged he block all attacks for 10 sec + avoid all parry/block...etc + bug with shield 4 all tanks 

Activities

CyunUnderis

CyunUnderis

2024-05-02 16:56

reporter   ~0042758

I tested on live and the 100% block despite the 4 hits for 10sc is already there. So the patch didn't introduce this bug.
CyunUnderis

CyunUnderis

2024-05-02 16:58

reporter   ~0042759

Maybe we can split this bug report in two :
- one about the PTS's version where Oathstone provides Unstoppable instead of Immovable
- one about the Live's version where Oathstone provides 100% block for the full duration (10sc) despite being hits 4 times
Emissary

Emissary

2024-06-05 00:32

manager   ~0043151

Hi,

Thank you for your detailed report. The issue with the Ironbreaker's Oathstone ability providing 100% block for 10 seconds despite the intended limit of 4 hits has been noted. Additionally, the description on the PTS did not reflect the changes correctly and mentioned the wrong immunity type.

Here are the updates:

The description on the PTS should include the additional information about the 6 seconds of Immovable to you and your Oath Friend within 50 feet.
The incorrect immunity type "Unstoppable" has been corrected to "Immovable," and this change will take effect in the next patch.
I will forward the issue with Oathstone not breaking on 4 hits to Dalen for further investigation and fixing.
Thank you for helping us improve the game!

Best regards,
Emissary
dalen

dalen

2024-07-07 10:06

manager   ~0043822

fixed for next patch

Issue History

Date Modified Username Field Change
2024-05-02 16:51 CyunUnderis New Issue
2024-05-02 16:56 CyunUnderis Note Added: 0042758
2024-05-02 16:58 CyunUnderis Note Added: 0042759
2024-06-05 00:32 Emissary Assigned To => dalen
2024-06-05 00:32 Emissary Status new => confirmed
2024-06-05 00:32 Emissary Note Added: 0043151
2024-06-23 21:10 Emissary Relationship added related to 0022917
2024-06-23 21:10 Emissary Relationship replaced has duplicate 0022917
2024-07-07 10:06 dalen Relationship added has duplicate 0022923
2024-07-07 10:06 dalen Status confirmed => resolved
2024-07-07 10:06 dalen Resolution open => fixed
2024-07-07 10:06 dalen Note Added: 0043822